Suddenly stop getting leads

Options
glebmx
glebmx Posts: 5
edited March 5 in Business Resources

Hi guys. I joined Thumbtack Pro in early January 2024 and quickly received my first lead on January 8th, one day after signing up. Between January 8 and February 5, I received 17 leads and was hired seven times, showing a promising start. My profile was nearly maximized; I regularly posted photos and accumulated 10 reviews, although I lack a website.

Surprisingly, my lead flow came to an abrupt halt after February 5th. It's been over a month without a single new lead, despite my active profile management and continued engagement. Initially, with a barely filled profile, my engagement was high, and now, despite improvements, I'm seeing no activity.

I've contacted support only to be told that my profile is ranking well in my area, but with no leads coming through, this feedback doesn't feel right to me. I'm concerned that a possible shadow ban or technical glitch is affecting my visibility. My efforts to help friends set up their Thumbtack profiles from my IP address or my failed attempt to generate a lead for my own profile may have triggered a problem. In addition, there was a brief issue where I couldn't lead myself, which was later resolved, and I also attempted to reload my account with $150, suspecting payment issues, to no avail.

I'm at a crossroads and considering starting over with another account if I can't resolve this confusing situation. Has anyone faced similar problems? Could this be related to my IP address activity or some other technicality I'm overlooking? Any insight or advice from fellow professionals or the Thumbtack team would be greatly appreciated. I'm eager to return to the platform's former momentum and continue to effectively serve clients.

Thank you in advance for your help and guidance.


Comments

  • DustiO
    DustiO Administrator, Moderator Posts: 1,659
    Options

    @glebmx have you checked your availability settings? I see that you have "12am-midnight" as your hours, but 12am and midnight are the same time - wondering if that may be the problem? Have you tried instead selecting "use any open day or time"? Maybe that would help (I am just guessing though). Otherwise everything looks good and it could be a simple matter of demand.

  • glebmx
    glebmx Posts: 5
    Options


    I don't see that I've set up the kind of timing you're talking about. Please send me a screenshot and show me where it says that. Here's my screenshot:



  • DustiO
    DustiO Administrator, Moderator Posts: 1,659
    Options

    You should be able to click the link I added above - or just go to your "calendar" tab and you should see "manage availability" there. Let me know if this helps at all!

  • glebmx
    glebmx Posts: 5
    Options

    Why when I click on your link I see this availability? It's different from when I click on Calendar in my profile.



  • DustiO
    DustiO Administrator, Moderator Posts: 1,659
    Options

    This is just taking you to where you adjust it, the calendar shows you a view of what is already set, hope that makes sense!

  • glebmx
    glebmx Posts: 5
    Options

    I see what the problem is. The link was to another business profile created an hour ago. Most likely the problem will not be solved. The account I described the problem with had everything ok in the avability settings.


  • DustiO
    DustiO Administrator, Moderator Posts: 1,659
    Options

    I would not recommend having two profiles - so I would delete the one you are not going to use. If you want to add another profile, you can do that in your existing account.

  • glebmx
    glebmx Posts: 5
    Options

    That's exactly what I did. I didn't create a separate account. I'm in the process of setting it up now

  • DustiO
    DustiO Administrator, Moderator Posts: 1,659
    Options

    Oh awesome! Best of luck! Let us know if you have any more questions. We also have our bi-weekly networking sessions where you can chat with other Thumbtack pros. You can find those here - we call them "CommuniTEA".